Hei vieras, tervetuloa!

Vaikuttaa siltä että olet uusi täällä? Jos haluat osallistua keskusteluihin, rekisteröidy valitsemalla joku painikkeista ohessa!

433 MHz laitteiden epäluotettava ohjaus

SimppaSimppa Member, Beta-käyttäjä Viestejä: 24
editoi marraskuu 2016 kohteessa Support
Ostin Cozifyn lähinnä nurkissa jo valmiiksi pyörivien 433 MHz laitteiden sekä myös zigbee ja z-wave tuen takia. Philipsin Huet ja zigbee laitteet toimivatkin ihan hienosti mutta 433 MHz härvelien kanssa menee hermot. Käytössäni on esim. Nexan LCMR-1000 releitä ja prooven pistorasioita. Niiden kaikkien kanssa on ongelmana isot viiveet toiminnassa (toisinaan kymmeniä sekuntteja) ja välillä ne eivät toimi ollenkaan. Olen koikeillut laitteiden poistoa ja uudelleen asennusta tuloksetta. Välillä kun hubin käynnistää uudelleen, saattavat laitteet toimia taas hetken. Myöskään laitteiden etäisyydellä Cozifystä ei näyttäisi olevan merkitystä. Mikä avuksi?
«13

Viestejä yhteensä

  • klampiklampi Member, Beta-käyttäjä Viestejä: 168 ✭✭
    Simppa kirjoitti:

    Mikä avuksi?

    En tosiaan tiedä, mikä avuksi. Hyvin samanlaiset kokemukset minullakin. 433 MHz yksisuuntaisesta tekniikasta johtuen nuo laitteet eivät voi olla yhtä luotettavia, kuin Zigbee-laitteet. Osaltaan ko. laitteiden halpa hintakin kielii siitä, että eivät ole niitä kaupan laadukkaimpia laitteita.

    Koska kuitenkin myös minulla on kokemuksia, että Cozify hubin uudelleen käynnistys auttaa hetken, ihan kaikkea syytä en olisi kaatamassa 433 MHz laitteiden niskaan. Jos syyllinen olisi aina 433 MHz laite, hubin uudelleen käynnistyksen ei pitäisi vaikuttaa yhtään mitään..
  • Kimmo RuotoistenmäkiKimmo Ruotoistenmäki Member, Cozify, Pilotti-käyttäjä, Beta-käyttäjä Viestejä: 204 mod
    Hei,

    - Kimmo
    klampi kirjoitti:

    Simppa kirjoitti:

    Mikä avuksi?

    Koska kuitenkin myös minulla on kokemuksia, että Cozify hubin uudelleen käynnistys auttaa hetken, ihan kaikkea syytä en olisi kaatamassa 433 MHz laitteiden niskaan. Jos syyllinen olisi aina 433 MHz laite, hubin uudelleen käynnistyksen ei pitäisi vaikuttaa yhtään mitään..
    Olemme tosiaan tehneet parannuksia hubin 433-toiminnallisuuteen kesän/syksyn releaseissa liittyen tuohon jumahtamiseen. Klampi, huomaatko edelleen resetoinnin auttavan asiaa?

    - Kimmo
  • klampiklampi Member, Beta-käyttäjä Viestejä: 168 ✭✭

    Klampi, huomaatko edelleen resetoinnin auttavan asiaa?

    - Kimmo

    Olen nyt ensi viikon puoliväliin reissussa. Palaan asiaan, kun olen taas kotona ja kun joku noista kolmesta hankalasta Nexan releestä taas temppuilee urakalla.
  • NikkeNikke Member Viestejä: 13
    Itsellä kanssa ollut ongelmia, isoja viiveitä ja välillä lopettaa kokonaan toimintansa ellei parita uudelleen. Tällä hetkellä nyt cozify hub istuu käyttämättömänä. Ei jaksanut tapella hubin kanssa. Tosiaan Mulla käytössä nexan lähettimiä ja vastaanottimia. Suoralla yhteydellä toimivat 90% paremmin.
  • Kimmo RuotoistenmäkiKimmo Ruotoistenmäki Member, Cozify, Pilotti-käyttäjä, Beta-käyttäjä Viestejä: 204 mod
    Nikke kirjoitti:

    Itsellä kanssa ollut ongelmia, isoja viiveitä ja välillä lopettaa kokonaan toimintansa ellei parita uudelleen. Tällä hetkellä nyt cozify hub istuu käyttämättömänä. Ei jaksanut tapella hubin kanssa. Tosiaan Mulla käytössä nexan lähettimiä ja vastaanottimia. Suoralla yhteydellä toimivat 90% paremmin.

    Nikke, 433-laitteilla on toki omat rajoitteensa verrattuna uudempaan teknologiaan. Mutta ei hubi huonompi pidä olla kuin niiden suora ohjaus. Sinultakin kysyisin, miltä ajalta kokemuksesi ovat? Teimme muutoksia 433-laitteiden käsittelyyn mm. parantaaksemme luotettavuutta ja 433-laitteiden aiheuttamaa kuormaa. Mikäli nykyisessä versiossa on ongelmia, jotka vaikuttavat johtuvan hubista, otamme nämä kommentit erittäin mielellään vastaan.

    - Kimmo/Cozify
  • amuamu Member, Beta-käyttäjä Viestejä: 348 ✭✭
    @Kimmo Ruotoistenmäki

    Myös itselläni on tällä hetkellä hyvin paljon ongelmia 433 MHz laitteiden ja Cozifyn välillä. Ennen suurta 433 MHz päivitystä laitteet toimivat mielestäni tyydyttävästi, nyt todella huonosti.
    Viive saattaa tosiaan olla kymmeniä sekunteja joskus jopa useita minuutteja.

    Suoralla yhteydellä (esim. Nexa seinäkatkaisija -> Nexa rele) ei ole ongelmia.
  • Kimmo RuotoistenmäkiKimmo Ruotoistenmäki Member, Cozify, Pilotti-käyttäjä, Beta-käyttäjä Viestejä: 204 mod
    Amu,

    Kiitos, selvitämme nyt mistä ongelmat johtuvat. Tämän päivän perusteella kyseessä on epäsäännöllisesti esiintyvä ongelma, joka ilmeisesti johtuu korotetusta väylätaajuudesta. Palaamme tähän.

    - Kimmo
  • PudemanPudeman Member, Administrator, Beta-käyttäjä Viestejä: 1,006 admin
    Nostetaan selvitystyön vaikeuskerrointa, sillä nyt nuo 433 laitteet tuntuvat pelaavan moitteetta. Jopa Nexan ulkoliiketunnistin on toiminut, niin kuin sen kuuluukin.
  • Jarno ViitasaariJarno Viitasaari Member Viestejä: 6
    Viimenen päivitys paransi Nexan laitteiden toimivuutta huomattavasti aikaisempaan versioon,jonka kanssa meinas hermot palaa totaalisesti...Ainoo noi Nexan ulkoliiketunnistimiin tarvis keksiä jotain kun jää usein vilkkumaan sovellukseen eli käskyt jää päälle.
  • SimppaSimppa Member, Beta-käyttäjä Viestejä: 24
    Alku näytti ihan hyvältä uusimman päivityksen jälkeen Nexan releiden toimivuuden suhteen. Nyt kuitenkin viiveet ovat palanneet ehkä jopa pahempina kuin aiemmin. Aika usein Cozify ei lähetä ohjauskäskyä ensinkään. Olisiko korjausta kohta tulossa?
  • MaranziMaranzi Member Viestejä: 15
    Terve,

    meillä ei tällä hetkellä yksikään Nexa -rasia toimi Cozify Hubin kautta. Ongelmat ovat alkaneet ihan hiljattain. Joskus joku rasia tottelee, mutta kammottavalla viiveellä. Tarkennus: Twilight:n kautta ohjattava Nexa -rasia toimii lähes oikein - vaikkakin sekin sekoilee nykyään ja mm sytytti lampun aamulla (kun hämärtyessä pitäisi sytyttää).

    Pikaista korjausta odotellen... Cozifyn ostettuani oli haasteita, mutta sittemmin järjestelmä on kyllä toiminut tosi hyvin, kunnes nyt lähes puhdas nolla-suoritus ;)
  • klampiklampi Member, Beta-käyttäjä Viestejä: 168 ✭✭
    Taitaa nämä 433 MHz ongelmat olla aika hankalia.

    Minun kokemusten mukaan viimeisin Cozify-päivitys auttoi. Tosin juuri ennen viimeisintä päivitystä poistin WC:stä Nexan katkaisijan ja korvasin katon perus G10-ledit Philips Hue:lla, koska oli tullut mitta täyteen temppuilevaa Nexaa. Tuo oli juuri se Nexa, joka eniten temppuili ja jossa ensimmäisenä ongelmat havaitsi.

    Kaksi muuta samanlaista tuntuu nyt kuitenkin toimivan aiempaa täsmällisemmin. Myös Nexan ulko-liiketunnistin toimii taas järkevästi, ei toitota koko ajan liikettä.

    Uutena on sitten tullut yhden LCMR-1000 releen pari kertaa tapahtunut tilanne, jossa tila ei ole muuttunut Cozify hubin käskyn mukaan. Ennen tuo laitetyyppi toimi täysin moitteetta. Kaksi muuta samanlaista laitetta on kuitenkin edelleen toiminut moitteetta.

  • KattiKatti Member, Beta-käyttäjä Viestejä: 47
    Nexan seinäkytkimiä on lakannut toimimasta. Hätäpäissäni vaihdoin jo paristonkin, mutta ei auttanut.

    LWST-605 -kytkimet toimivat jotenkuten viidennellä painalluksella, mutta WBT-912 on aivan pimeänä. Mistä päästänkin siihen että kun Cozifyssä ei logia näe niin en tiedä onko lähetin rikki vai vika Cozifyssä.

    Joka tapauksessa odottelen luotettavampaan tekniikkaan perustuvia kytkimiä kuin kuuta nousevaa.
  • Pasi StåhlPasi Ståhl Member, Beta-käyttäjä Viestejä: 50
    Cozify kertoo kytkimen asetuksissa, milloin laite on viimeksi havaittu. Tämä aika kertoo, milloin on viimeksi saatu signaali Nexan seinäkytkimeltä.
    Logi olisi kyllä kiva. Näkisi, onko Cozify lähettänyt signaalin.
  • tonytony Member, Administrator, Cozify, Beta-käyttäjä Viestejä: 157 admin
    Tutkimme tätä 433MHz ongelmaa ja toivottavasti löydämme tähän syyn ja pääsemme julkaisemaan korjauksen seuraavassa releasessa.

    Muutama asia joita voi kokeilla.

    - Hubin uudelleenkäynnistys
    - Laitteen parituksen purkaminen ja uudelleenparitus

    Palaamme tähän ongelmaan mahdollisimman pian.

    - Tony / Cozify
  • KattiKatti Member, Beta-käyttäjä Viestejä: 47
    Pasi Ståhl kirjoitti:

    Cozify kertoo kytkimen asetuksissa, milloin laite on viimeksi havaittu. Tämä aika kertoo, milloin on viimeksi saatu signaali Nexan seinäkytkimeltä.

    Seinäkytkimissä ei minulla näy ko. tietoa vaikka muun tyyppisissä laitteissa näkyykin.


  • PudemanPudeman Member, Administrator, Beta-käyttäjä Viestejä: 1,006 admin
    Paina vielä tuossa näkymässä oikeassa yläkulmassa näkyvää rataskuvaketta ja vieritä alas. Sama toiminto on esim. Nexan kauko-ohjaimissa.
  • klampiklampi Member, Beta-käyttäjä Viestejä: 168 ✭✭
    klampi kirjoitti:

    Myös Nexan ulko-liiketunnistin toimii taas järkevästi, ei toitota koko ajan liikettä.

    Tähän päivityksenä, että Nexa ulko-tunnistin toimii vähän paremmin, kuin joskus, mutta tänään jumiutui toitottamaan liikettä.
  • amuamu Member, Beta-käyttäjä Viestejä: 348 ✭✭
    @cozify @Kimmo Ruotoistenmäki

    Mikä mahtaa olla tilanne 433 MHz korjauksen osalta?

    Tilanne on tällä hetkellä se, että Cozify ottaa vastaan Nexan seinäkytkimien ja Prooven liiketunnistimien signaalin jotakuinkin ongelmitta, mutta ei lähetä 433 MHz signaalia ulospäin. Ei Nexan releille, eikä ovikellon hälyttimelle.

    Todella turhauttavaa, kun nuo ovat aikaisemmin toimineet luotettavasti ja teidän tekemien softa korjauksien jälkeen lakanneet kokonaan toimimasta.
  • FArmyFArmy Member, Beta-käyttäjä Viestejä: 10
    amu kirjoitti:

    @cozify @Kimmo Ruotoistenmäki

    Mikä mahtaa olla tilanne 433 MHz korjauksen osalta?

    Tilanne on tällä hetkellä se, että Cozify ottaa vastaan Nexan seinäkytkimien ja Prooven liiketunnistimien signaalin jotakuinkin ongelmitta, mutta ei lähetä 433 MHz signaalia ulospäin. Ei Nexan releille, eikä ovikellon hälyttimelle.

    Todella turhauttavaa, kun nuo ovat aikaisemmin toimineet luotettavasti ja teidän tekemien softa korjauksien jälkeen lakanneet kokonaan toimimasta.

    Hei,

    Olen aivan samassa tilanteessa amun kanssa. Katkaisija kytkee teemoja päälle pois, mutta yksikään pistorasia ei toimi halutulla tavalla. Suora ohjaus katkaisijalta pistorasiaan toimii.

    Lämpömittareilta päivittyy tiedot, mutta lämpötilan perusteella tapahtuvat 433MHz toiminnot eivät toimi. Tästä syystä varaston lämmitys, jonka tulisi mennä päälle 12 Celsiuksen alituksesta, oli mennyt päälle, mutta ei koskaan pois. Lämmöt varastossa n.20 Celsiusta.

    Toivottavasti saatte nopeasti edes jotain purkkaa tarjolle näihin ongelmiin.

  • Kimmo RuotoistenmäkiKimmo Ruotoistenmäki Member, Cozify, Pilotti-käyttäjä, Beta-käyttäjä Viestejä: 204 mod
    Hei,

    Pahoittelut ongelmista. Asiaa tutkitaan edelleen. Kuten aiemmin kerroin, ongelmaa on vaikea toistaa ja siksi tämä on meille haasteellinen. Iso apu olisi, jos voisimme ottaa yhteyttä teihin, joilla ongelmia esiintyy. Jos voisitte laittaa meille viestiä [email protected] lyhyen ongelmakuvauksen kera, niin otamme tarvittaessa teihin suoraan yhteyttä.

    - Kimmo/Cozify
  • bigfootbigfoot Member, Beta-käyttäjä Viestejä: 64
    Meillä ainakin molemmat autopistokkeet (Nexa) sekoilee niin paljon että on ollut pakko siirtyä takaisin kello-ohjaukseen. Aiemmin toimivat Cozyssä moitteetta.
    Auto-teemat menee itsekseen päälle ilman sääntöjä. Teemat on säädetty menemään päälle laitteista (pistoke).
    Molemmille autoille on omat teemansa. Samalla saadaan tiettyihin sisälämppuihin värikoodi siitä että lämmitimet on päällä.
    Ongelmana on että laite-näytössä ko pistorasioiden täpät on mustina, vaikka lohkoämmittimet ja sisälämmittimet puhisee täysillä molemmissa autoissa!
    Tulee kalliiksi kun yhteensä 5KW on koko yön päällä. No toisaalta ei ollut yhtään lunta kummankaan auton katolla, ikkunoista puhumattakaan.
  • samppasamppa Member, Cozify Viestejä: 649 mod
    Yksi syy viiveisiin ja laitteiden toimimattomuuten voi olla myös Prooven liiketunnistin, joka lähettää purskeen viestejä joka liikkeestä ja peittoaa alleen kaikki muut komennot joita Hubi on lähettämässä. Etenkin jos liiketunnistin on asennettu paikkaan jossa liikutaan paljon, esim olohuoneeseen, on seurauksena että muiden 433MHz laitteiden luotettavuus saattaa kärsiä. Tällaisissa paikoissa Zigbeellä toimiva liiketunnistin on paras ratkaisu. Esimerkiksi Centralite 3-Series Micro Motion Sensor: http://www.cozify.fi/collections/devices/products/centralite-3-series-micro-motion-sensor

    Olemme tehneet myös joitain korjauksia 433 MHz käsittelyyn, jotka tulevat seuraavan päivityksen mukana.

    t.Samppa / Cozify
    t. Samppa \ Cozify
  • amuamu Member, Beta-käyttäjä Viestejä: 348 ✭✭
    @cozify @samppa @Kimmo Ruotoistenmäki

    Mielestäni viivettä hubin ja 433 MHz laitteen välillä ei pysty perustelemaan 433 MHz kaistan ruuhkalla. Eikös hubi lähetä käskyn ainoastaan kerran, kun sääntöön on niin määritetty? Paluutietoa signaalin perillemenostahan ei 433 MHz laitteilta tule.

    Esimerkkitilanne, jossa Zigbee liiketunnistimella ohjataa 433 MHz relettä:

    1. Zigbee liiketunnistin lähettää hubille tiedon liikkeestä
    2. Hubi lähettää 433 MHz releelle käskyn mennä päälle

    Eihän tässä tilanteessa merkittävää viivettä voi syntyä kuin hubissa itsessään.

    Jos hubi lähettäisi 433 MHz signaalin säännön mukaisesti viiveettä, niin signaali joko menee perille (rele menee päälle ilman merkittävää viivettä), tai ei mene perille (rele ei mene päälle ollenkaan).
    Se että rele menee päälle esim. minuutin viiveellä ei selitä mikään muu kuin se, että hubi on lähettänyt signaalin minuutin viiveellä.

    Tämä taas viittaa vahvasti siihen, että hubin sääntöjen käsittelyssä on ongelma.

    Korjatkaa toki jos olen väärässä.
  • samppasamppa Member, Cozify Viestejä: 649 mod
    @amu Olet oikeassa ja tuollaisen minuutin viiveen selittäminen on hankalaa.
    Helpottaisi huomattavasti jos virheen saisi jotenkin toistettua. En ole sitä saanut toistettua vielä kertaakaan..
    Toistuuko viive juuri tuolla Zigbee liiketunnistin ja Nexa rele yhdistelmällä?
    t. Samppa \ Cozify
  • samppasamppa Member, Cozify Viestejä: 649 mod
    @amu Sain kyllä toistettua virheen jossa kaukosäätimellä ohjasin kahta relettä päälle ja noin joka kymmenes kerta toinen rele (jälkimmänen) ei reagoinutkaan kuin vasta 10-40 sekunnin kuluttua, tai aiemmin jos joku toinen 433 MHz viesti oli lähdössä. Eli lähtevä viesti puskuroitui maksimissan minuutiksi. Tämä vika on korjattu uudessa päivityksessä, joka julkaistaan piakkoin.
    t. Samppa \ Cozify
  • samppasamppa Member, Cozify Viestejä: 649 mod
    @bigfoot Tärkeisiin kohteisiin kannattaa käyttää jotain muuta ohjausta kuin 433 MHz perustuvia, koska niillä ei voida taata oikeaa toimintaa.

    Hieno idea muuten koodata tilatieto värilamppuun!
    t. Samppa \ Cozify
  • FArmyFArmy Member, Beta-käyttäjä Viestejä: 10
    Näin joulun lähestyessä ja kuusen valoja asennellessa iski jälleen huoli 433MHz ongelmista. Lähinnä joudunko sammuttamaan kuusen valot kiskomalla töpselin seinästä.

    Yksikään 433MHz pistorasia ei ole toiminut vähään aikaan ja eukkokin naputtaa kun ei valot toimi. Nohevana miehenä päätin selvittää ongelmaa. Käytössäni on nexan pistorasioiden lisäksi Prooven lämpömittareita, jotka möykkää 433MHz taajuudella. Tein brutaalin siivouksen ja poistin Proovet hubista ja paritin muutamat pistorasiat uudestaan. Ja niin ne rupesi toimimaan. Lisäsin vielä uuden pistorasian joulukuusen valoillekin ja sekin toimii.

    En sano että tämä on lopullinen ratkaisuni, mutta tähän hätään arvostan enemmän pistorasioiden ohjausta kuin ullakon lämpötilatietoa.

    Jos muilla kohtalotovereilla on mahdollisuus/intoa testata lämpömittareiden disablointia ja sen seurauksia niin hyvä.
    Cozifyn poppoolle suosittelen että tsekkaa ainakin onko tässä teoriassa mitään järkeä.

  • samppasamppa Member, Cozify Viestejä: 649 mod
    @FArmy : Hienoa että sait pistorasiat toimimaan. Mutta mielenkiintoista että uudelleen paritus auttoi, koska nuo 433 MHz sensorit (mm.lämpötila anturi ja liiketunnistin) lähettävät tilatietoa aina riippumatta siitä onko niitä paritettu vai ei. Varmin tapa sammuttaa ne on ottaa patterit pois.

    Minulla on tässä neljä Nexan sisä/ulko lämpömittaria ja ne lähettää viestejä niin harvakseltaan etten saa mitään virheitä toistettua. Mutta yksikin liiketunnistin saattaa jumittaa viestit jos se havaitsee kokoajan liikettä.

    @amu
    Tänään hubiin tulee ohjelmistopäivitys joka parantaa 433 MHz laitteiden toimintaa etenkin alle minuutin viiveiden osalta. Viestien katoamiseen todennäköisin syy on kaistan tukkeutuminen joko liikesensorin tai muun anturin takia ja tähän emme ikävä kyllä voi vaikuttaa hubin puolella.

    t.Samppa / Cozify
    t. Samppa \ Cozify
  • IiroSIiroS Member Viestejä: 76
    Omaan kokoonpanoon kuuluu 433 MHz -repertuaarista lähinnä pistorasioita, alakerrassa on yksi 433 MHz liiketunnistin suihkussa. Kun oleilen yksin talossa eri kerroksessa kuin suihku, silti tuo pistorasioiden viive /toimimattomuus on kyllä havaittavissa, joten vaikea uskoa että ongelma piilee kaistan tukkitumisessa liiketunnistimen vuoksi. Ongelma ilmaantui tässä pari päivitystä sitten, joten jotain hubisoftassa muuttui, mikä tuota jumiutumista/viivettä nyt aiheuttaa. Muu kokoonpano kun on pysynyt about samana.

    Sinällään ongelma tuntuu korostuvan mitä kauempana Cozify-laitteesta pistorasiat on. Keittiössä viive saattaa olla 5-10 sekuntia (etäisyys 6 m), makuuhuoneessa (8 m) viive on about sama. Alakerrassa, jonne on pisin matka viive on luokkaa 15-30 sek/ei toimi.

    Mystinen juttu kyllä. Aikaisemmin alakerrassa 433 MHz pistorasiat kun toimi moitteetta, eikä teknologian puolesta selkeää loogista syytä tuolle viiveelle kyllä löydy. Ainoa mitä keksisin tuon tyylisen ongelman syyksi olisi jos hubiin on ohjelmoitu joku "varmistuskäsky" -toiminto. Sellainen, joka varmistaa esim. Zigbee-liiketunnistimen havaitessa signaalin, että 433 MHz signaali pääsee varmasti hubilta perille lähettämällä pistorasialle käynnistymiskäskyn toistetusti muutaman sekunnin viiveellä. Tyyliin 1-4 käynnistyskäskyä esim. 5 sek välein. Joku siinä sitten mättää, joko niin että ekat käskyt ei lähde tai lähetystehossa on eroja niin että lähetysteho kasvaa jostain syystä ensimmäisestä käynnistyskäskystä hiljakseltaan niin että vasta 3. tai 4. käsky menee perille. Tai sitten se signaali puuroutuu syystä tai toisesta.
Kirjaudu sisään tai Rekisteröidy kommentoidaksesi.